Theme for GSX1400Owners.ORG for SMF 2.1

Started by LandyVlad, Feb 05, 2020, 02:50 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

lesmond

Quote from: LandyVlad on Mar 23, 2021, 04:51 PMGood O. I have a few days off next week - might get a chance to duplicate the forum as a test site.


I have duplicated the site on a test site, works ok until I add TP, TinyPortal blocks wont show at all for some reason.
You can see here https://gsx.lesmonds.com/index.php its in Maintenance Mode, but you can login with your normal admin account.

The only person who got all his work done by Friday was Robinson Crusoe

lurkalot

Quote from: lesmond on Mar 25, 2021, 06:39 AMI have duplicated the site on a test site, works ok until I add TP, TinyPortal blocks wont show at all for some reason.


Try using TP 1.6.9 if you want to stick to TP 1.x.x series Les,  Versions prior to 1.6.6 need updating for security reasons.  Personally I'd go for TP 2.0.1

lesmond

Quote from: lurkalot on Mar 25, 2021, 02:53 PMTry using TP 1.6.9 if you want to stick to TP 1.x.x series Les,  Versions prior to 1.6.6 need updating for security reasons.  Personally I'd go for TP 2.0.1

Uninstalled 1.6.5 and deleted it, then tried 2.0.1 and got an error..

Database Error
Duplicate column name 'content'
File: /home/xxxxxx/public_html/gsx/Packages/temp/install.php
Line: 888

The only person who got all his work done by Friday was Robinson Crusoe

lurkalot

Strange, not seen that one Les.  What SMF RC3 are you running, the released one from SMF downloads, or the latest from the GitHub repo?

lesmond

Quote from: lurkalot on Mar 26, 2021, 03:54 AMStrange, not seen that one Les.  What SMF RC3 are you running, the released one from SMF downloads, or the latest from the GitHub repo?
The one from SMF downloads.
I uninstalled TP2.0.1 and tried TinyPortal 1.6.9 that installed OK, but still no blocks or panels.

The only person who got all his work done by Friday was Robinson Crusoe

Skhilled

How did you create the test site...exactly?

lurkalot

Mar 26, 2021, 02:27 PM #21 Last Edit: Mar 26, 2021, 02:31 PM by lurkalot
Quote from: lesmond on Mar 26, 2021, 04:22 AMThe one from SMF downloads.
I uninstalled TP2.0.1 and tried TinyPortal 1.6.9 that installed OK, but still no blocks or panels.

You can't go back to TP 1 series after installing TP 2, at least not without losing your block content etc, that's due to the database changes.  TP 2.0.1 should run fine on RC3 though,  You getting any errors?

QuoteNOTICE! because of the database changes in this version there's no going back to TP 1.x.x after installing version 2.0.1. You can install previous versions, but by doing that you WILL lose TP data and you will need to manually fix or recreate your content!!! For these reasons it's advised to backup your database and files before proceeding.

lurkalot

Les, perhaps PM me a temp admin login and I'll take a quick peek to see if I can find out why it's not working.  It's strange because I have several sites running 2.1 RC3 and TP 2.0.1 without problems.

lesmond

@LandyVlad we have fixed the test site now for SMF 2.1 RC3 and TP 2.0.1 many thanks to @lurkalot for his help :rgton

You can have a look Here use the same login for your main site.

some things will still cause errors because none of the mods or attachments are installed, so don't worry about those  :emb

The only person who got all his work done by Friday was Robinson Crusoe

LandyVlad

Looking good mate. :rgton  :D  :vcool

I've taken a few screenshots and will run it my my admins and see what they reckon !
I reject your reality, and substitute my own.

LandyVlad

Feedback from other admins.

QuoteI think it looks new & fresh, yet still easily recognisable & familiar.  Bring it on.  :rgton

QuoteI've got to say this looks really cool and up to date with other sites  looks great  gets my vote

QuoteThat's very similar to the Triumph forum theme and style (from when I was a Triumph owner) and it worked well, so it's a thumbs up from me  :rgton

A couple of things would be cool, if possible.

Using this image as an example:
You cannot see attachments on this board.

1. Each board has a Suzuki 'S' beside it, do these need to be the same or could each board have a differnt one?

2. Is it possible to have a unique icon in each of the category headings?  (So for example, technical could have a spanner icon, classifieds a $ sign icon, etc)

3. The category headings have a red line around them, (although the bottom one if there doesn't show up. Is it possible to have the red line surround that category box as well as the boards withing that category (ie one that goes around the outside of all of them)? Oh the same applies to the stats box too, FYI.

Cheers mate  :rgton  :rgton  :rgton
I reject your reality, and substitute my own.

lesmond

Quote from: LandyVlad on Apr 06, 2021, 05:48 PM1. Each board has a Suzuki 'S' beside it, do these need to be the same or could each board have a differnt one?
found this mod by SychO https://custom.simplemachines.org/mods/index.php?mod=4224 could work for this, I have added a few, but some I cant find in fonts awesome

Quote2. Is it possible to have a unique icon in each of the category headings?  (So for example, technical could have a spanner icon, classifieds a $ sign icon, etc)
Sorry I dont know how that can be done :(

Quote3. The category headings have a red line around them, (although the bottom one if there doesn't show up. Is it possible to have the red line surround that category box as well as the boards within that category (ie one that goes around the outside of all of them)? Oh the same applies to the stats box too, FYI.
Done
[/quote]

The only person who got all his work done by Friday was Robinson Crusoe

LandyVlad

Apr 07, 2021, 06:44 PM #27 Last Edit: Apr 07, 2021, 11:47 PM by LandyVlad
1. Awesome  ;) (Have to be font-awesome icons do they?)
2. There's probably a way - perhaps I'll ask on the official SMF forum and see if anyone there has an idea.
3. Cool.
:vcool

-----------------------
OK update re item 3.
I think it looked better previously rather than have these additional red lines that go around each board.  I really wanted the outline of ALL of a category not each individual board element however I am pretty sure that's not readily possible.  So perhaps back to how it was before that change please Les.
I reject your reality, and substitute my own.

lesmond

Quote from: LandyVlad on Apr 07, 2021, 06:44 PM1. Awesome  ;) (Have to be font-awesome icons do they?)
Yes, unless @SychO knows another way :)
Quote2. There's probably a way - perhaps I'll ask on the official SMF forum and see if anyone there has an idea.
Maybe, I did a search @ smf nothing came up.
 
:vcool
Quote-----------------------
OK update re item 3.
I think it looked better previously rather than have these additional red lines that go around each board.  I really wanted the outline of ALL of a category not each individual board element however I am pretty sure that's not readily possible.  So perhaps back to how it was before that change please Les.

If you mean these sections


then I have done this....

and removed the other red outlines.

The only person who got all his work done by Friday was Robinson Crusoe

lesmond

Made a few changes to the board icons. :emb


The only person who got all his work done by Friday was Robinson Crusoe