What current 2.1.x file to use for upgrade from 2.0.18 ?

Started by LandyVlad, Sep 27, 2021, 01:16 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

LandyVlad

let's say I am going to update a test forum from 2.0.18 to SMF 2.1RC4...

Which file should I actually be using?

When I checked on Github I couldn't find an RC4 file (presumably as that's already been released) so should I use the current code for 2.1final? Or... ?

Answer appreciated. :)

Answer including relevant link doubly appreciated.  :rgton
I reject your reality, and substitute my own.

LandyVlad

I reject your reality, and substitute my own.

lesmond

Try this https://www.simplemachines.org/community/index.php?msg=3958589 and download the 'nightly_upgrade'

But I would recommend using the main download from smf downloads https://download.simplemachines.org/ using the RC4 Large upgrade on that page.

The only person who got all his work done by Friday was Robinson Crusoe

LandyVlad

OK so I am using that now

running upgrade.php

at Step 3 backup.
It's sitting at 4% total, 7% step
Time Elapsed: 140 mins, 35 seconds.
You cannot see attachments on this board.
So yeah that's not right shouldn't be taking anywhere near this long !

What to do?
I reject your reality, and substitute my own.

Bigguy

Did it start to run again. How's this goin for ya. :???

LandyVlad

I reject your reality, and substitute my own.

Bigguy

So it looks like the same problem I had which was reported fixed on GH. You said you got the files from the nightly build ?? Try the ones from GH. They may work better. One more question though...Do you have a lot of attachments ??

LandyVlad

I did but when I culled the forum (deleted most boards) that should have culled the attachment stuff too, I assume.
I reject your reality, and substitute my own.

Bigguy

You may have to look through attachment settings and the like to see if there are any problems. That's were I would start anyway.

LandyVlad

I reject your reality, and substitute my own.

Bigguy


Bigguy


LandyVlad

Nah I'm using the official RC4 build.

Kindred said there's a way to tell the upgrader not to do backups before doing the upgrade - biut I couldn't find that when running upgrade.php
I reject your reality, and substitute my own.

Bigguy

Downloading it from GH is the official RC4. As for what Kindred said, there should be a checkbox when you start the upgrader to backup or not. Just don't check the box. Make sure you take a database backup from cpanel before doing the upgrade though.

Bigguy

Quote from: Bigguy on Sep 28, 2021, 09:53 PMDownloading it from GH is the official RC4
Well...it's not the one on the downloads page on SMF but it has more fixes and is more advanced than what is there.