Images

Started by Ronald, Mar 02, 2021, 10:07 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Ronald

Mar 02, 2021, 10:07 AM Last Edit: Mar 02, 2021, 12:21 PM by Ronald
I have installed a SMF 2.1 RC3 board as another arcade site.
Looking in the database for different items, I don't see where the banner is hosted, I like to change banners and I always add them to the images in the database.
Also where do images get installed.

Anyone give me the location.

LandyVlad

@lesmond may be able to help with this.
I reject your reality, and substitute my own.

lesmond

Not sure what your ask Ron, images are normally stored under each theme in the respective folders /Themes/default/images

The only person who got all his work done by Friday was Robinson Crusoe

Ronald

Quote from: lesmond on Mar 03, 2021, 10:23 AMNot sure what your ask Ron, images are normally stored under each theme in the respective folders /Themes/default/images

Only shows the smf logo on the right corner.in default skin only..

Skhilled

Are you trying to make the smf logo show in other themes? If so, they may have removed it when they created the themes. however, you can make it show if you wish.

Ronald

In RC3 in the index.css there is no logo

Skhilled

Mar 11, 2021, 06:48 AM #6 Last Edit: Mar 11, 2021, 07:48 AM by lesmond
Quote from: Skhilled on Mar 08, 2021, 08:52 AMAre you trying to make the smf logo show in other themes?
If so, then you will need to add it to: /Themes/default/images/smflogo.svg


You may also need to add code to each custom theme in one or more of the following files...although, there may be other ways to do it:

\Themes\default\index.template.php
\Themes\default\css\responsive.css
\Themes\default\css\index.css

For index.template.php, look of this in the default to see:

Code (Line 332:) Select
', empty($settings['site_slogan']) ? '<img id="smflogo" src="' . $settings['images_url'] . '/smflogo.svg" alt="Simple Machines Forum" title="Simple Machines Forum">' : '<div id="siteslogan">' . $settings['site_slogan'] . '</div>', '';

lesmond

Mar 11, 2021, 07:53 AM #7 Last Edit: Mar 11, 2021, 07:56 AM by lesmond
You can force the logo/banner for each theme by changing the code in index_template.php

Code (find) Select
echo '
<div id="header">
<h1 class="forumtitle">
<a id="top" href="', $scripturl, '">', empty($context['header_logo_url_html_safe']) ? $context['forum_name_html_safe'] : '<img src="' . $context['header_logo_url_html_safe'] . '" alt="' . $context['forum_name_html_safe'] . '">', '</a>
</h1>';

Code (Change too) Select
echo '
<div id="header">
<h1 class="forumtitle">
<a id="top" href="', $scripturl, '">', empty($context['header_logo_url_html_safe']) ? '<img src="' . $settings['images_url'] . '/custom/logo.png" alt="' . $context['forum_name_html_safe'] . '">' : '<img src="' . $context['header_logo_url_html_safe'] . '" alt="' . $context['forum_name_html_safe'] . '">', '</a>
</h1>';


Change '/custom/logo.png" to the destination folder of your logo

The only person who got all his work done by Friday was Robinson Crusoe

Skhilled

Ah! I was trying to remember that but it's been so long. LOL