Oct 22, 2020, 11:09 PM

News:

Stable SMF release ver.: 2.0.17


registration error - smf 2.0.15

Started by lesmond, Jul 04, 2019, 03:05 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

@rjen

There you go: STRICT mode is set default to ON in MySQL 5.7...

reference... https://www.percona.com/blog/2016/10/18/upgrading-to-mysql-5-7-beware-of-the-new-strict-mode/

You will have to ask the host to deactivate strict mode for you site...

lesmond

its not my site nore my host, but I have sent in a ticket to his hosting.

The only person who got all his work done by Friday was Robinson Crusoe


lesmond

Well they got there answer...not sure what to do now :(

QuoteHello,

Unfortunately this option is disabled for all accounts on shared/business hosting. Please consider upgrading to a VPS or a dedicated server.

The only person who got all his work done by Friday was Robinson Crusoe

@rjen

Upgrade to 2.1 quickly or find another host: they have upgraded their sql version causing the issues...

lesmond

Quote from: @rjen on Jul 05, 2019, 10:40 PMUpgrade to 2.1 quickly or find another host: they have upgraded their sql version causing the issues...
I don't think they will upgrade, they have almost 6000 members, and he just paid a year on his hosting.

I also tried to register a member manually, still get the same error!!

QuoteField 'buddyList' doesn't have a default value
File: /home/xxxxxx/public_html/forums/Sources/Subs-Members.php
Line: 775

The only person who got all his work done by Friday was Robinson Crusoe

@rjen

If they don't want to upgrade (understandably atm since 2.1 is still RC) then the options are very limited: go for the dedicated hosting plan or move hosts...

... and then turn off STRICT mode...

Seriously, SMF 2.0.x is not equiped to deal with the STRICT sql mode. You can still set that field default to NULL and hope that that next problem is not stopping people from registering, but it's not a long term fix...


lesmond

I made a copy on my hosting, and all works fine, so yes it his hosting thats the problem. problem is he just paid for a new year on his hosting plan!

The only person who got all his work done by Friday was Robinson Crusoe

@rjen

Quote from: lesmond on Jul 05, 2019, 08:19 PMHello,

Unfortunately this option is disabled for all accounts on shared/business hosting. Please consider upgrading to a VPS or a dedicated server.

too bad he did not check with his host before ...

Oldiesmann

Quote from: lesmond on Jul 06, 2019, 09:22 AMI don't think they will upgrade, they have almost 6000 members, and he just paid a year on his hosting.

I also tried to register a member manually, still get the same error!!


You need to find out what table the "buddyList" column is in, then set it to allow NULL values. The problem here is that you're not inserting any data into that column at that point but you told the database not to allow NULL values, so MySQL has no idea what to do with that field.

As far as the other error goes, if your host won't let you set custom SQL modes then your only option is to either have someone properly rewrite that query or keep adding columns to the "GROUP BY" clause until MySQL shuts up about it.
Cincy Space - now open! https://www.cincyspace.net