Jan 26, 2020, 09:53 PM

News:

How many easter eggs have you found....


QUICK NEWS

{NEW} - A new tutorial for Github is ready for your veiwing in the articles section.

{OLD} -New boards have been introduced. Stop on in and check it out.

Video of the week


Internal Links

SMF Sites

Quick Info

Upgrading PHP

Started by LandyVlad, Dec 12, 2019, 01:57 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

LandyVlad

Dec 12, 2019, 01:57 AM Last Edit: Dec 12, 2019, 02:04 AM by LandyVlad
My 2.0.15 forum is still running on PHP 5.6

My host has recommended that I upgrade it (to make it more efficient in processing so my site isn't slowing down), and no doubt it's overdue.

So

1. What PHP version should I upgrade to? 7.1? (I gather 2.0.15 isn't 7.2 compatible, but 2.0.16 will be?)

2. What actions/changes (if any) do I need to do to ensure it all still works properly when I upgrade?

Thanks
I reject your reality, and substitute my own.

lurkalot

All mine are running fine on 7.1 but I probably run different mods on my sites, it would depend if all your mods are happy on 7.1 etc. SMF itself is fine.

LandyVlad

Aside from changing the PHP version on the hosting account what else do I need to do SMF wise? - if anything.

How do I know if mods will work on PHP 7.1?

I'm running the current versions of-

1.   @mention members   
2.   Automatic Attachment Rotation (and Resize)   
3.   Birthday Posts
4.   Bot Buster
5.   Copyright and Footer Links
6.   Country Flags
7.   Downloads System
8.   Google Member Map
9.   Hall Of Fame
10.   httpBL   
11.   Image Processing Memory Limit
12.   Like Posts
13.   Responsive Curve
14.   Show JDALLAUI in Post and PM
15.   SMF Gallery Pro   
16.   SMF Gallery Pro SSI
17.   SMF Links
18.   SMF Post Prefix
19.   Sortable Packages (and Installed Time)
20.   Stop Spammer
21.   TinyPortal
22.   Topics Created And Participated In
23.   Yet Another YouTube BBCode Tag
I reject your reality, and substitute my own.

nidec

I didn't think @mention members worked on anything above 2.0.7

Skhilled

Yes, SMF 2.0.15 will run fine on PHP 7.1. You can use a mod that will allow you to use 7.2 but it gives errors it your error log. You can just delete the errors but AFAIK there's no other problems I'm aware of.

There may be problems using certain mods, however.

Quote from: nidec on Dec 12, 2019, 04:39 PMI didn't think @mention members worked on anything above 2.0.7

Most mods that far back will still work with 2.0.15 as not much has changed in the database, just coding changes. Read the support topics for it to see if there are any changes you may need to make. Otherwise, you should be able to "emulate" it when installing it.

LandyVlad

IIRC The first version of SMF I installed was 2.0.13 and I've upgraded twice from there.

@mention members has always worked for me flawlessly. It's a great mod, but obviously its built into 2.1 so I wouldn't bother introducing to any 2.0.x forum at this point.


I reject your reality, and substitute my own.