Jan 27, 2020, 01:50 PM

News:

How many easter eggs have you found....


QUICK NEWS

{NEW} - A new tutorial for Github is ready for your veiwing in the articles section.

{OLD} -New boards have been introduced. Stop on in and check it out.

Video of the week


Internal Links

SMF Sites

Quick Info

Database error [Solved]

Started by lesmond, Apr 15, 2019, 01:34 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

lesmond

Apr 15, 2019, 01:34 PM Last Edit: Apr 15, 2019, 03:45 PM by lesmond
A site I help maintain, has a DB error showing on the front home page, from what I can see it may be something to do with his tinyportal, I have checked all running block and turned them off one by one. :dontknow


Expression #9 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'xxxxx_0725607345.a.id_attach' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
File: /home/xxxxx/public_html/forums/Sources/TPortal.php
Line: 1685

here is a couple of errors from the log
8: Undefined index: tp_panels
File: /home/xxxx/public_html/forums/Themes/default/languages/TPShout.english.php (tp_below sub template - eval?)
Line: 133

2: in_array() expects parameter 2 to be array, null given
File: /home/xxxx/public_html/forums/Themes/default/languages/TPShout.english.php (tp_below sub template - eval?)
Line: 123

The only person who got all his work done by Friday was Robinson Crusoe

lurkalot

Les, can you post this over at our support forum, see if the guys can find the cause.

lesmond

I have done, but I think it maybe they need an TP update, They only call me in when they have an error, which is not often.

The only person who got all his work done by Friday was Robinson Crusoe

lurkalot

Yeah just seen you've posted there. Sorry.

Just asked about SMF / TP versions etc in that post.

lurkalot

Hopefully tino put you on the right track over there.  That TP version is a tad old which is probably the reason for the problem.

lesmond

Updated his TP to the latest, went OK, some of the text is a bit bigger in the articles, but thats there problem now.

Thanks Mate

The only person who got all his work done by Friday was Robinson Crusoe

lurkalot

Quote from: lesmond on Apr 15, 2019, 03:20 PMUpdated his TP to the latest, went OK, some of the text is a bit bigger in the articles, but thats there problem now.

Thanks Mate

Hmm, shouldn't have changed the articles, unless they get resaved. I would turn the editor off in article settings , because of the different editors between those versions, and advise only to turn it on for new articles. 

Saving articles created with the old editor might (will) change the format slightly.

Articles created from scratch using the new editor should be fine.

Bigguy

Sounds like this has been taken care of :rgton

lesmond


The only person who got all his work done by Friday was Robinson Crusoe