Jun 20, 2019, 05:03 AM

News:

How many easter eggs have you found....


Uninstall Mod.'s SMF 2.1 RC1

Started by Ronald, Apr 14, 2019, 12:55 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Bigguy

Quote from: Oldiesmann on Apr 14, 2019, 09:20 PMThere is no code showing because that mod doesn't edit any files. It just runs the install.php script and adds three new files, which likely means it's using integration hooks to do whatever it needs to do.
I started to think that after I parsed it the last time.

Quote from: Ronald on Apr 14, 2019, 09:25 PMBut how do you uninstall this mod. I have tried three times, and after a long period of time it ends up showing a blank page with all kinds of codes..which makes me think it's an error..
It does sound like something is wrong though. It's not supposed to do that.

lurkalot

Quote from: Bigguy on Apr 14, 2019, 09:56 PMI started to think that after I parsed it the last time.
It does sound like something is wrong though. It's not supposed to do that.

Just a thought. If it's a old out of date mod, or for a different version than 2.1 then it's probably not removing the hooks, therefore still thinks its installed.

Skhilled


lurkalot

Quote from: Skhilled on Apr 15, 2019, 08:55 AMIf it is not removing the hooks then try "fix_packages":

https://download.simplemachines.org/index.php?tools

Does that tool work in 2.1?

I would just remove the hooks in the 2.1 admin panel myself, that's built in.  Go admin and put hooks in the search.

Ronald

Quote from: lurkalot on Apr 15, 2019, 09:23 AMDoes that tool work in 2.1?

I would just remove the hooks in the 2.1 admin panel myself, that's built in.  Go admin and put hooks in the search.

That worked, Google is gone.

Skhilled

Quote from: lurkalot on Apr 15, 2019, 09:23 AMDoes that tool work in 2.1?

I would just remove the hooks in the 2.1 admin panel myself, that's built in.  Go admin and put hooks in the search.
Cool, didn't know that.

Ronald

Quote from: lurkalot on Apr 15, 2019, 09:23 AMDoes that tool work in 2.1?

I would just remove the hooks in the 2.1 admin panel myself, that's built in.  Go admin and put hooks in the search.

I did it this way. After being away from the forum for a short time, I came back to roughly 2900 errors of:



Type of error: General:
Hook call: function "google_analytics_load_theme" in file /home/coffeeti/public_html could not be called.
 https://coffeetimeunlimited.com/index.php?action=viewsmfile;filename=current-version.js

Ronald
Today at 12:18:29 pm
50.115.176.5
87585ef3d3f4dbd4d65fd7005ca11a28

lurkalot

Quote from: Ronald on Apr 15, 2019, 12:22 PMI did it this way. After being away from the forum for a short time, I came back to roughly 2900 errors of:



Type of error: General:
Hook call: function "google_analytics_load_theme" in file /home/coffeeti/public_html could not be called.
 https://coffeetimeunlimited.com/index.php?action=viewsmfile;filename=current-version.js

Ronald
Today at 12:18:29 pm
50.115.176.5
87585ef3d3f4dbd4d65fd7005ca11a28

Was that before you removed the hooks.  You might have uninstalled and it removed the mods files but if the hooks are still calling those missing files.

If you no longer have any mods installed, if it was me I'd just upload a fresh set of files from the large upgrade zip. Obviously for the version you are running now. https://download.simplemachines.org/

Unless anyone else has a better idea.

Ronald

I keep getting these errors by the dozens. for google analytics. I could not remove the mod. so I deleted it.

I was looking in the cpanel and under Languages I see the google analytics, is it ok to delete these files.

Ronald

Quote from: lurkalot on Apr 15, 2019, 01:07 PMWas that before you removed the hooks.  You might have uninstalled and it removed the mods files but if the hooks are still calling those missing files.

If you no longer have any mods installed, if it was me I'd just upload a fresh set of files from the large upgrade zip. Obviously for the version you are running now. https://download.simplemachines.org/

Unless anyone else has a better idea.

Got all the errors after deleting the mod.. I am thinking of just upgrading to RC2 and hope all is well after that..

Think this will work..

SychO

Hooks are usually stored in the database, so a fresh set of files or an upgrade won't stop the errors (unless this hook is somehow actually being called from a file, in wich case I'm wrong here)

You can either try the "fix_package" tool from here https://download.simplemachines.org/index.php?tools, But I do not know if it works with 2.1

Or you can just go to Admin -> Maintenance -> Integration hooks
look for google_analytics_load_theme and disable it, but you won't be able to enable it again because that admin panel is still getting worked on.

Ronald

Quote from: SychO on Apr 15, 2019, 01:59 PMHooks are usually stored in the database, so a fresh set of files or an upgrade won't stop the errors (unless this hook is somehow actually being called from a file, in wich case I'm wrong here)

You can either try the "fix_package" tool from here https://download.simplemachines.org/index.php?tools, But I do not know if it works with 2.1

Or you can just go to Admin -> Maintenance -> Integration hooks
look for google_analytics_load_theme and disable it, but you won't be able to enable it again because that admin panel is still getting worked on.

Your a life saver. Thanks, this got the errors to stop.

Later on tonight I am going to do the upgrade to RC2

lurkalot

Quote from: Ronald on Apr 15, 2019, 02:23 PMYour a life saver. Thanks, this got the errors to stop.

Later on tonight I am going to do the upgrade to RC2

Ok, so what exactly did you do to stop those errors?

SychO

Oh and if the panel gives you the option to actually remove that hook, remove it :)

Bigguy

You might have to click twice to remove it...unless that was fixed.